PDA

View Full Version : Viewing Japanese Characters in your browser



Chi
26th July 2001, 13:59
This post is in response to one or two people asking how to display Japanese fonts properly in their Web Browser. There are two issues related to this; One is ensuring that your browser is using the correct document encoding, and the other is ensuring that you have a font installed on your computer which contains the japanese charater set.

Document Encoding/Character Set
There are three main types of Japanese Document Encoding types; JIS, EUC and Shift-JIS.

JIS - Japanese Industrial Standard. This is the most widely used encoding type.

EUC - Extended UNIX Code. This is more common on UNIX/Linux machines.

Shift-JIS - This is a (strange) Microsoft encoding based loosely on JIS. It is therefore most common on Windows (and suprisingly enough Macintosh) machines (and since I would hazard the majority of people posting on this forum are using eith Mac or Windows machines, it is the most likely one to come across here).

Help! I can only see squiggles, not Japanese characters! (AKA How to switch Document encoding)
I will deal first with standard Windows running PCs.

1) In most browsers, there is an option to change the document encoding. Change the document encoding to Japanese (Auto Detect) or Japanese (Shift-JIS). In Internet Explorer this is found in the View menu under Encoding and you will have a list of Document Encoding Types to choose from. If you do not see any Japanese Encoding Types listed, In Netscape Navigator this is in the View menu under Character Set.

Help! My browser doesn't list any Japanese Document Encodings!
You have an old browser! Your options:
i) get a new one! (Netscape 4+ or IE 4+ shold do the trick)

ii) if you are using Internet Explorer and your PC is running Windows 98/2000/ME, go to Windowsupdate at http://windowsupdate.microsoft.com. You are looking to install the Japanese Browsing Enhancements (and if you actually want to try inputting those funny looking symbols for yourself, you will need an Japanese Input Method Editor or IME, also available from Windowsupdate).

If you are running Windows 95, you will need to install the Japanese language pack. You should be able to find this on Microsoft's website.

If you are running MacOS 8.5+, you need to install Multi-lingual Internet Access. Instructions for doing this are here - http://www.jp.bluemountain.com/home/fonts.html

So what did that do? All I see are squares now instead of squiggles!
You either do not have a Japanese font installed, or need to configure your browser to use a Japanese font. If you are seeing squares in Internet Explorer, it is most probably the former (so get the font by going to Windowsupdate. If you are using another browser, its difficult to tell. If you think you have a Japanese-capable font on your machine, try changing the default font in your browser to it. An example of a Japanese-capable font is "MS Gothic". So e.g. to set Netscape 4.7 to use this font go to: Preferences -> Appearance -> Fonts. On the dialogue box titled "For the Encoding:" choose Japanese, then for Variable Width font choose the Japanese font (in this case MS Gothic). If it still doesn't work, you might need to check the option "Use my default fonts, overriding Document-specific fonts" but be warned this will make all webpages display using those fonts, and hence many pages will look horrid!

If you are not using Internet Explorer, and need a Japanese font, you can either download one of the Internet, or simply install the I.E. Japanese language enhancements just for the font!

The following link may be useful for further information:
http://www.kanzaki.com/jinfo/japanese.html

To see if your browser is displaying Shift-JIS correctly, look at the following two lines (which say "hajimemashite, mina san" in hiragana, and then "Biiru o kudasai!" ;) to test hiragana, katakana and kanji)

はじめまして?Aみなさん?B
ビ?[ルお下さい?I

Hope this is of help! Please feel free to post/PM any comments/corrections/problems!

Regards,

Chris.

P Goldsbury
27th July 2001, 00:14
Originally posted by Chi
This post is in response to one or two people asking how to display Japanese fonts properly in their Web Browser. There are two issues related to this; One is ensuring that your browser is using the correct document encoding, and the other is ensuring that you have a font installed on your computer which contains the japanese charater set.

Document Encoding/Character Set
There are three main types of Japanese Document Encoding types; JIS, EUC and Shift-JIS.

JIS - Japanese Industrial Standard. This is the most widely used encoding type.

EUC - Extended UNIX Code. This is more common on UNIX/Linux machines.

Shift-JIS - This is a (strange) Microsoft encoding based loosely on JIS. It is therefore most common on Windows (and suprisingly enough Macintosh) machines (and since I would hazard the majority of people posting on this forum are using eith Mac or Windows machines, it is the most likely one to come across here).

Help! I can only see squiggles, not Japanese characters! (AKA How to switch Document encoding)
I will deal first with standard Windows running PCs.

1) In most browsers, there is an option to change the document encoding. Change the document encoding to Japanese (Auto Detect) or Japanese (Shift-JIS). In Internet Explorer this is found in the View menu under Encoding and you will have a list of Document Encoding Types to choose from. If you do not see any Japanese Encoding Types listed, In Netscape Navigator this is in the View menu under Character Set.

Help! My browser doesn't list any Japanese Document Encodings!
You have an old browser! Your options:
i) get a new one! (Netscape 4+ or IE 4+ shold do the trick)

ii) if you are using Internet Explorer and your PC is running Windows 98/2000/ME, go to Windowsupdate at http://windowsupdate.microsoft.com. You are looking to install the Japanese Browsing Enhancements (and if you actually want to try inputting those funny looking symbols for yourself, you will need an Japanese Input Method Editor or IME, also available from Windowsupdate).

If you are running Windows 95, you will need to install the Japanese language pack. You should be able to find this on Microsoft's website.

If you are running MacOS 8.5+, you need to install Multi-lingual Internet Access. Instructions for doing this are here - http://www.jp.bluemountain.com/home/fonts.html

So what did that do? All I see are squares now instead of squiggles!
You either do not have a Japanese font installed, or need to configure your browser to use a Japanese font. If you are seeing squares in Internet Explorer, it is most probably the former (so get the font by going to Windowsupdate. If you are using another browser, its difficult to tell. If you think you have a Japanese-capable font on your machine, try changing the default font in your browser to it. An example of a Japanese-capable font is "MS Gothic". So e.g. to set Netscape 4.7 to use this font go to: Preferences -> Appearance -> Fonts. On the dialogue box titled "For the Encoding:" choose Japanese, then for Variable Width font choose the Japanese font (in this case MS Gothic). If it still doesn't work, you might need to check the option "Use my default fonts, overriding Document-specific fonts" but be warned this will make all webpages display using those fonts, and hence many pages will look horrid!

If you are not using Internet Explorer, and need a Japanese font, you can either download one of the Internet, or simply install the I.E. Japanese language enhancements just for the font!

The following link may be useful for further information:
http://www.kanzaki.com/jinfo/japanese.html

To see if your browser is displaying Shift-JIS correctly, look at the following two lines (which say "hajimemashite, mina san" in hiragana, and then "Biiru o kudasai!" ;) to test hiragana, katakana and kanji)

はじめまして?Aみなさん?B
ビ?[ルお下さい?I

Hope this is of help! Please feel free to post/PM any comments/corrections/problems!

Regards,

Chris.

The matter is not so simple. At present my computer is set to Japanese (a forth setting you did not mention (jido hambetsu), but the kanji written above is impossible to read no matter which setting I use.

Since I have a Japanese Mac with the Japanese version of OS 9.1 and a Japanese Version of Internet Explorer 5.0, I have all the Chinese characters I need.

Webmasters always tell me that the problem lies with my computer settings, but I am not so sure. I can no longer use Chinese characters with this forum (after the latest revision) or with the newly revised AikidoJournal.com. However, I can do so on Jun Akiyama's Aikiweb.com. So I think the problem lies with E-budo.com operating software.

Yours sincerely,

Peter Goldsbury
____________
P A Goldsbury,
Graduate School of Social Sciences,
Hiroshima University

red_fists
27th July 2001, 01:40
Hi Peter.

Can you send me a Copy of your Browser setting?

I will ask a friend of mine to configure his Mac the same way and we can see where the problem lies.

I have worke din Computers now for 17yrs, my friend is a Web-Administrator
with longer Computer experience than me.

If you prefer to speak to him directly, let me know and I can send you his E-Mail addy.

I live in Tokyo, he lives in Tatebayashi/Gunma, but he will be visting me this weekend.

P Goldsbury
27th July 2001, 04:54
Originally posted by red_fists
Hi Peter.

Can you send me a Copy of your Browser setting?

I will ask a friend of mine to configure his Mac the same way and we can see where the problem lies.

I have worke din Computers now for 17yrs, my friend is a Web-Administrator
with longer Computer experience than me.

If you prefer to speak to him directly, let me know and I can send you his E-Mail addy.

I live in Tokyo, he lives in Tatebayashi/Gunma, but he will be visting me this weekend.

Peter,

Thank you for the message.

Depending on where I am, I use three different computers, from all of which I can send messages to the three bulletin boards with which I am currently registered (E-Budo; Aikido Journal; Aikiweb). The computers are: G4 with OS9.1/Explorer 5; G4 Powerbook with OS X and Explorer 5.1; and the 20th Anniversary Mac with OS 9.1/ Explorer 5.0. But the problem is common to all three. The G4 Powebook with OS X is set up in English and the browser is set to Latin. But even if I change the settings, I cannot input Chinese characters. Similarly with the other two computers, which have Explorer 5.0 with the language setting at Nihongo Jido-hambetsu, as I stated in my earlier post.

Problems first arose when Stanley Pranin revamped Aikido Journal. I could not use Communicator 4.7 and switched to Explorer 5.0. The problem was solved until the latest revisions to the AJ bulletin board. Similarly with E-Budo.com. But last week I posted some Japanese on Aikiweb with no problem.

I have never needed to change any of the default settings on my own web browser and this is why I think the problem lies with the bulletin boards.

Anyway, please have your friend work at the problem and e-mail me at pag@mocha.ocn.ne.jp if you need to. Thanks in advance.

Yours sincerely,

Peter Goldsbury,
____________
P A Goldsbury,
Graduate School of Social Sciences,
Hiroshima University

inter-ninja
1st November 2001, 09:38
uh, not to be an ass, but you used the wrong "o" in "biru o kudasai." you wrote "o" the vowel, and it should be "o" the particle. Sorry, I can't show you because I don't have any writing software on this computer now, but I can still read it. You know what I'm talking about, right? Use the other "o"

Oh well, not that it matters for Japanese encoding test purposes ;)

Jrn Stahl

Chi
1st November 2001, 10:56
Originally posted by inter-ninja
uh, not to be an ass, but you used the wrong "o" in "biru o kudasai." you wrote "o" the vowel, and it should be "o" the particle. Sorry, I can't show you because I don't have any writing software on this computer now, but I can still read it. You know what I'm talking about, right? Use the other "o"


Yes, thanks for pointing this out, but I am aware of this (I noticed it myself when I re-read this thread a few months back, but really couldn't be bothered to change it - the idea was to test your ability to view hiragana, katakana and kanji, not show how crap my skills in nihongo are :) ). It should indeed be "wo" (or を).

Regards,

Chris.

Adam DArcy
2nd November 2001, 22:26
怒った狼?uお?v?A?uお?v?Iいろんな顔で ?Eい?Eう?E?E?E